page top

Online Banking access, is your web browser up to date?

Attention: open in a new window. Print

Thursday, 25 October 2018

Did you know your browser could be out of date? Our online banking site is moving to limit access of old web browsers to better protect your security and safety while banking online.

From the 1st November you’ll need to make sure you’re using one of the following browsers, these are the minimum supported versions:

  • Google Chrome (desktop & mobile) - version 30+ (current v44)
  • Mozilla Firefox(desktop & mobile) - version 27+ (current v39)
  • Microsoft Internet Explorer (desktop & mobile) - version 11+ (current v11 or Edge)
  • Mozilla Firefox(desktop & mobile) - version 27+ (current v39)
  • Apple Safari(desktop only) - version 7+ (current v9)
  • Apple Safari(mobile only) - version 7+ (current v9)
  • Android Browser (mobile only)- version 5+ (current v8) NOTE: browser version in line with Android OS version (i.e. v5 = Lollipop/v5.0-5.1.1)

Any previous versions will be unable to access Online Banking so it’s important you keep your browser software up to date.

For more information on Browser Security and FAQs can be found here.

Comments

Name *
Code   
Submit Comment