Which phones or devices can I use Google Pay on?

Your Android device must be running on Android 5.0 (Lollipop) or higher, support near field communication (NFC) and host card emulation (HCE) technology.

Can't find what you're looking for?

 

Contact us to speak with a Customer Service Specialist.

Customer Feedback