Can I update my Qudos Bank app to the latest version if I haven’t updated my device operating system?

The minimum operating requirements for the new App are as follows:

  • iOS software version 11.0 and above
  • Android software version 6.0 and above

Please update your mobile phone to the latest operating system to be able to download the most recent Mobile App version. As we try to accommodate to a large range of devices, devices running older system versions will no longer be supported.

Download a better banking experience today

Can't find what you're looking for?

 

Contact us to speak with a Customer Service Specialist.

Customer Feedback